問題
Box Driveで「プロキシが安全なリクエスト(https)をサポートしていることを確認し、もう一度やり直してください」というエラーが発生し、ログインできなくなったり、同期や操作ができなくなったりします。
根本原因
利用しているプロキシサーバーによっては、Box接続に必要なホスト名を許可していない場合、httpプロトコル通信でリダイレクトされ、エラーとなる場合があります。
解決方法
利用しているプロキシサーバーで、「Boxアプリケーションおよびサービス用のファイアウォールの設定」に記載されているホスト名を許可してください。
https://support.box.com/hc/ja/articles/360043696434
また、http通信プロトコルでプロキシサーバーにリダイレクトしないよう、設定を確認してください。