Issue
An error message “Please ensure your proxy supports secure requests (https) and try again” appears in Box Drive, preventing users from logging in, syncing, or performing operations.
Root Cause
Depending on the proxy server in use, if the required hostnames for Box connections are not allowed, the connection using the http protocol may be redirected, resulting in an error.
Resolution
Ensure that your proxy server allows the hostnames described in the following article: Configuring A Firewall For Box Applications and Services
https://support.box.com/hc/en-us/articles/360043696434
Additionally, check the http connection protocol settings to prevent redirecting to a proxy server.