Issue
When using Outlook on a computer with Box Drive installed, the user receives an excessive number of error messages saying “Unable to open folder. [Filename] could not be opened. Please try again.”
Root Cause
A certain process is making excessive access attempts to a Box Drive folder, causing the system to fail to handle the load, resulting in errors.
Resolution
To immediately mitigate the issue on the customer’s side, you can identify the process causing the error and add it to the registry settings. This can prevent the relevant process from accessing the Box Drive folder.
How to identify the problematic process (Windows)
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From the files with the prefix, Box_Streem (e.g., Box_Streem_1_yyyy-mm-dd.log) under “C:\Users\<UserName>\Box\Box\Logs\”, open the file corresponding to the date and time when the issue occurred.
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Check if there is a process making excessive access attempts at the date and time the issue occurred. If the same process (e.g., WmiPrvSE.exe) is making these accesses, numerous log entries as shown below will appear.
yyyy-mm-dd 23:13:19.700 INFO 0x00003dac [winfs:573][onGetFileInfo] [WmiPrvSE.exe] "\SampleFolder"
yyyy-mm-dd 23:14:19.700 INFO 0x000037ec [winfs:453][onOpenFile] [WmiPrvSE.exe] "\SampleFolder", shareMode: 0x7, desiredAccess: 0x100001
yyyy-mm-dd 23:14:19.700 INFO 0x00003da8 [winfs:494][onCloseFile] [WmiPrvSE.exe] "\SampleFolder"
If you have any difficulty identifying the process causing this issue, please contact our support team.
How to add the process name to the registry
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Quit Box Drive.
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Using the Registry Editor, move to HKEY_LOCAL_MACHINE\SOFTWARE\Box\Box.
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Make a new multi-line string value (REG_MULTI_SZ) named BannedProcessNames (if it does not exist).
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Double-click BannedProcessNames and add the process name (e.g., WmiPrvSE.exe).
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Exit the Registry Editor.
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Launch Box Drive.